C语言并查集题目 C语言题目:有多少张桌子--并查集

软件发布|下载排行|最新软件

当前位置:首页IT学院IT技术

C语言并查集题目 C语言题目:有多少张桌子--并查集

hnjzsyjyj   2021-09-07 我要评论
想了解C语言题目:有多少张桌子--并查集的相关内容吗,hnjzsyjyj在本文为您仔细讲解C语言并查集题目的相关知识和一些Code实例,欢迎阅读和指正,我们先划重点:C语言并查集,C语言题目,下面大家一起来学习吧。

【Problem Description】问题描述

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

今天是伊格纳修斯的生日。他邀请了很多朋友。现在是吃晚饭的时间了。伊格纳修斯想知道他至少需要多少张桌子。你必须注意,并不是所有的朋友都互相认识,而且所有的朋友都不想和陌生人呆在一起。
这个问题的一个重要规则是,如果我告诉你A认识B,B认识C,这意味着A,B,C相互认识,所以他们可以呆在一张桌子上。
例如:如果我告诉你A知道B,B知道C,D知道E,那么A,B,C可以呆在一张桌子上,而D,E必须呆在另一张桌子上。所以伊格纳修斯至少需要两张桌子。

【Input】输入

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 输入以整数T(1<=T<=25)开始,表示测试用例的数量。然后,T测试用例随之出现。每个测试用例从两个整数N和M开始(1<=N,M<=1000)。N表示朋友的数量,朋友标记为从1到N。然后M行跟随。每行由两个整数A和B(A=B) 意思是朋友A和朋友B彼此认识。两个案例之间将有一个空白行。

【Output】输出

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

对于每个测试用例,只需输出Ignatius至少需要多少个表。不要打印任何空白。 

【Sample Input】样本输入

2
5 3
1 2
2 3
4 5

5 1
2 5

【Sample Output】样本输出

2
4

【Code】代码

#include <iostream>
using namespace std; 
const int maxn=1005;
int pre[maxn]; 
int find(int x) {
	if(x!=pre[x]) pre[x]=find(pre[x]);
	return pre[x];
} 
void merge(int x,int y) {
	if(find(x)!=find(y)) pre[find(x)]=find(y);
} 
int main() {
	int T,N,M;
	int p,q;
	scanf("%d",&T);
	while(T--) {
		int ans=0;
		scanf("%d%d",&N,&M); 
		for(int i=1; i<=N; i++) pre[i]=i; 
		for(int i=1; i<=M; i++) {
			scanf("%d%d",&p,&q);
			merge(p,q);
		} 
		for(int i=1; i<=N; i++) {
			if(find(i)==i) ans++;
		} 
		printf("%d\n",ans);
	} 
	return 0;
}
 
 

/*
in:
2
5 3
1 2
2 3
4 5
5 1
2 5
out:
2
4
*/

总结

本篇文章就到这里了,希望能够给你带来帮助,也希望您能够多多关注的更多内容!

Copyright 2022 版权所有 软件发布 访问手机版

声明:所有软件和文章来自软件开发商或者作者 如有异议 请与本站联系 联系我们